Hypno Firmware 2.2

New firmware can be found here!

With the many filesystems and individual file situations out there we appreciate your patience while we iron out incompatibilities.

Patch notes:

  • USB Stick MP4/JPEG Loading ( Supported Filesystems: vfat ext2 ext3 ext4 ntfs-3g ntfs exfat hfsplus)

    • MP4 sample file: Cube.MP4

    • JPEG sample file: Triangle.JPEG

    • Place files in root directory

    • Use 640x480 or 720x480 .MP4s (480p30) for best performance (Convert w/ Handbrake, Drop down to 480p30fast)

    • For image loading, Use square or common (640x480 or 720x480 recommended) resolutions.

  • Help Mode shows filenames when indexing through files

  • USB Preset Backup

    • USB source saved via filename
  • NDI now stops sending when it doesn’t sense it is in use.

  • NDI SDK updated to version 5


Hi Ron, continuing from my other thread, here is one of the images I was having trouble with loading on this firmware. BMP wasn’t supported for attachment here, but I can email you the 32-bit transparent BMP I was trying as well if you’d like. Is transparency something you expect to work? I wasn’t sure if it would since JPEG doesn’t support transparency and common BMP formats don’t either, but I expected this non-transparent image to work. Also I had it saved with .JPG as the extension, not sure if that matters; I think I saw it included in a list of supported extensions on the release notes when I downloaded the firmware.


Anyways, I’ll try out those sample files and see if maybe it’s some other issue on my end.

edit: OK, I reformatted the USB stick (same sandisk cruzer blade 16gb, model SDCZ50-016G-B35) with exfat still, 32kb allocation unit size), loaded both sample files, and my own image. Turned on helper text, and attached stick. I saw the cube briefly and text indicated the cube file loaded, but then the cube disappeared after a second or two and there is no longer the extra shape LED color. Will try reformatting again and only putting the sample images. If that doesn’t work, I’ll try NTFS and FAT32. Will report back after testing.

Thanks will try this image right now. Just to be clear, inserting the cube mp4 only loads the video then the teal shape page disappears again?

FAT32 will probably be most consistent of the bunch though I tested exfat and it appeared to work fine on my end.

I was able to recreate issues with image loading on this build i think there may have been a weird issue when I exported above firmware image, checking on this now.

same results on exFAT 32kb allocation unit with only the 2 sample files
NTFS 4096 byte allocation unit: no new shape or text indicating it loaded, but Polarization B changed after a few seconds for some reason
FAT32 8192 byte allocation unit: This works, I can see the cube! But only the animated cube works. Triangle image does not work, and none of my own images work. I tried putting only images on the drive and it still “loads” them and the 6th shape is selectable, but no image displays. I can index through them, but the helper text is very garbled and disappears very quick, so hard to tell what I’m even selecting. I noticed this as well when I just had the cube and triangle loaded, cube video was fine and displayed the filename when indexing, but triangle image was blank and garbled text.

edit: Ahhh, I see you’re finding issues with images as well. That’s OK for me; I have some cool apps I can use to make fun animations out of my images, which I planned to do anyways. I figured images would be easier to test with first lol. Also now that I think about it, yeah, fat32 generally is the most compatible with various systems. I think this drive actually defaults to that when I go to format it.

1 Like

OK gotcha thanks for your feedback, i will try NTFS 4096 and put fat32 as recommended filesystem for now.

1 Like

Sounds good! Tag me if you want me to test any fixes or anything before publishing. I’ll be unavailable on the 18th/19th (traveling for this gig), but outside of that I’ll be happy to do more testing. Really great timing that this firmware came out right as I’m finally getting back into all this (all my creative stuff went on hold after house flooded earlier in the year; dealing with insurance and contractors was a nightmare, but I’m finally past it all). btw, really glad the helper text made it into one of the updates since I last used this; really really great to have a reference for exactly what I’m modifying when I touch things, especially since video isn’t my main focus usually

1 Like

Sorry to hear about the flooding, thats rough :frowning: … Glad you’ve got that situation more or less sorted and are back in video world!

Glad you’re into the help mode! It was requested a lot and I’m hoping to keep pushing it until it starts to function as a sort of “on board manual”. Should prove to be useful for file browsing in the future too.

Thanks for the offer to test more it is much appreciated! I think I just found the bug w the images so I will be uploading a new image to the link above very soon! (Will make another post here when it is finished being uploaded)

1 Like

This “should” be fixed please try the new link in the wiki (Here it is right here also.)

plz lmk how it works for you when you are able @TechnoMancy


Following the firmware update process as before… but this time my laptop is not recognising the hypno at all. Worked first time before.

Tried different laptop, still nothing. Tried windows and ubuntu. Still not seen by etcher.

Hypno boots up fine and works but can’t update it currently.

Any help very welcome.

Update: tried turning on help mode while in update mode and the screen changed to this:

Following the same steps gives me this:

Did you remember to flip the little switch on the back of the Hypno into update mode? I only ask because I’ve been there before…

Otherwise, we have troubleshooting steps for this very issue located on this page - Hypno Set Up & Troubleshooting Manual - Sleepy Circuits

See Steps 2 and 8.

When I get to step 4 of trouble shoot 8 Hypno doesn’t appear in Etcher.

I’m using the original usb cable and working hdmi cable.

Reseated and still nothing.

Are you using the USB port on the front of the Hypno? Every time I’ve updated the firmware, I’ve spent an hour or two struggling because I misread step 6 of the instructions to mean front USB on my PC lol. RPiboot didn’t detect it either until I realized I needed to plug into the other port. Then I had another issue where it kept failing immediately because I was pulling the image off a network drive.

1 Like

@Syntheist Have you been through all of these steps in Section 2? –

Compute Module does not initialize in Balena, or is not recognized by my computer

  • Ensure that Hypno is isolated from all accessories

  • Connect Hypno directly to a computer using the provided microUSB cable with no hubs or adapters

  • Try another microUSB cable (cables < 6’ are recommended)

  • Attempt the update on another computer

  • If none of the above helps, attempt the EMMC test described in Section 8

“Missing Drivers” error in Etcher on Windows:

And it seems like you have already tried everything in Section 8, correct?

Ok, just finished updating and testing; images are working as expected now! Even the 32-bit transparent BMP loads, although it doesn’t handle the transparency well. I realize now though that transparency is pointless and a black background is all that’s needed


What does this mean? I didn’t see anything obvious in any of the other documentation.

Are you able to play two movies at once or is it only one side at a time? But so far it is working very well on the one side and thanks for the color refresh.


1 Like

Since the video selection on Hypno is a sort of indexing…

If you rearrange/add files in the directory it won’t effect recall, but if you change the filename it will break the preset.

so…it works nice!

One at a time, unfortunately

2 videos at once is not tested and would take more dev time to implement, though I wouldn’t get my hopes up too high for this tiny processor its already handling quite a bit and I’m not so sure it would work in a workable framerate.

Glad you’re digging that OKLab color space!! Its more perceptually uniform!!!


I kept repeating the steps in point 8, changing one parameter at a time and eventually at 2am I got the new firmware to load.

Thanks for the help.

The new colour palette is awesome, feels more cohesive and the way the different colours play together feels like a real upgrade.


Overall, this looks great! A few issues I’ve noticed:

  1. When I turn on polarization for image shapes, the aspect ratio of the resulting shape is not always a circle, depending on the image aspect ratio.
  2. The PDF manual linked at Hypno Manual - Sleepy Circuits doesn’t mention the image/video shape in the “Shape A” box on page 1.

It would be nice to see some tiling options for video sources. Right now, they’re mirrored in the x+y dimensions, but it would be nice to be able to tile them without any mirroring, so they don’t flip!