Hypno 2.4-Release

Maybe I’m missing something but did the 2.4 update file get moved? I can’t seem to find a link to DL it on the Firmware page. Only 2.3 seems to be available as a link.

Hey sorry yes I took it down for the time being since there is a gnarly bug with the midi echos which regularly causes crashes on shape switch, I am working on getting a test version out today and hoping to get the replacement up early next week!

Sorry about that, this version (and honestly this whole week) kinda went off the rails and I’m working on resolving it as fast as humanly possible.

3 Likes

Yer doing good. You added a lot, and are trying to really make this device capable of utilizing the mezzz. Keep it up!

That said I found another thing which eliminates something I did with the unit:
Cropping the Y axis of a video/image now causes it the image to jump and snap around a lot. 2.3 was a very smooth adjustment which made it ideal for causing some pumping motions. Now, it’s pretty much unusable to me as a shifting parameter, seems better for just setting it once and never touching it.

One of the parameters I’d love to see a change on is rotate. It’s just a very steppy parameter but I understand the challenge of only having 127 steps via CC to rotate nearly 360 degrees. I know this is a personal thing and most people may not have an issue with it, But I’d love to see it rotate smoothly even if there was less degrees of change available. Likely not on your list of changes or options to put in, but some food for thought!

1 Like

I’m getting the same issue when trying to select the Hypno in balena - it says too small and I can’t select it. Have you figured out how to get it to install correctly?

Thanks.

You’re using the cm4 version? He updated that and it worked for me, however…

Ron appears to be working on a lot of bug fixes that presented themselves on the 2.4 version. Unless you’re dying to try out the mezzz with your hypno, I would wait until he pushes out a fixed firmware. I went back to 2.3 after a headache inducing amount of problems popped up for me with the 2.4 update, especially if using multiple midi devices.

The quirks of 2.3 I have already been working around and am familiar with, so I’d rather continue using that stable version unless you wanna help with some bug reporting :stuck_out_tongue:

1 Like

Thanks for your response.

I have the cm3 PI3 (HDMI on left side and composite on front)

I will go back to 2.3 as you mentioned and just wait for the next release.

Looks like new versions were released with some bug fixes. Give it a shot! Make sure you get the right image for the model of pi/cm you have

Hey Ron! I see you updated and fixed some bugs. Will try it later.
Quick question, is there a way to turn off midi echos? I just wonder if my midi controller (nanokey studio) will have struggles with that.
Chances are I can turn off midi receive in the controller which I will check out.

I didnt add an op for disabling echo, simply turn off the recieve on your nanokey for now but if there is some weird issue please do let me know.

Versions are up and seemingly working, @NoNazPete and I have been going back n forth confirming the image on the chat. Only thing right now is the PI3 image is too big so I’m uploading a smaller one so the old CM3 Hypnos work, that should be swapped in by the end of the day.

Also the posters from higher up in this thread will hopefully be happy to hear that you can change Hypno’s MIDI channel via config.txt now.

2 Likes

@SleepyRon I’m getting this message when trying to select it the Hypno as a drive. Is there a workaround? I have the PI3 version.

Yes I just mentioned this above…

the PI3 image is too big so I’m uploading a smaller one

the CM3 sized image just finished uploading, here it is directly but the link on the firmware page is now also this one: HypnoPi3CM3-2.4.2.img.gz

Thank you. Everything worked out great.

1 Like

Maybe I missed it in the docs, what is the name of the new config option to set the midi channel?

@n8k Hey there! Pop the SD card into a computer and open the config.txt,

scroll to the very bottom and look for the line “hypno_midi_channel”

there, you can replace “16” with any midi channel number of your choice.

Save and quit, eject and back into hypno!

Thanks.
For anyone else interested, the name is hypno_midi_channel