Novation Launch Control XL MKII MIDI Device Not Recognized on Hypno

Hi there,

I’ve set up my Novation Launch Control XL MKII on all of the correct Channels (CH 16) and uploaded the user profile to my device and my Pi4 Hypno will not recognize it.

Things I’ve tried:

  • Both the USB 2.0 and 3.0 ports (and tried them with it plugged it on startup of the Hypno)
  • Activating any of the Hypno controls before trying my MIDI controller
  • Tried several different MIDI profiles
  • Resetting my Hypno

I’m all out of ideas at this point and would love some suggestions on where to go next. Let me know if I can provide any additional information but otherwise I’ve attached a screenshot of the MIDI profile I’m using for my device.

Note: I’m not using the bottom row of pads hence why they are still on CH 1


Out of curiosity, have you tried plugging it in after the hypno is already booted? Just going by the circled numbers in the manual pic, this might be what is being suggested.

Just tried this again and yea, that doesn’t work either.

Are you booting the XL in low power mode? If not, try that? I don’t have one myself but it’s worth a shot. There’s a low-power start-up procedure documented in the XL manual, for iPads, etc. If it’s already in low-power mode anyway, try disabling it instead!

You say the Hypno doesn’t “recognise” it… Does the XL light up? Even if the Hypno doesn’t seem to recognise it, it should provide power over USB. Can you select templates/profiles on the XL using the front panel (making sure you are selecting the correct user profile directly once it’s powered up)?

Next thing I would suggest is trying it with a powered USB hub if you have one, just in case that works. But after that it’s probably a case of Doctor Google to see if other people have had issues with using an XL as a class compliant MIDI device.


I didn’t know about a low power mode, ill look into that!

And yes, when i plug it in the lights turn on and i am able to toggle to the user profile that i made for the Hypno to no avail. Ill look into a powered USB hub ad a solution if toggling power modes doesn’t help bc that’s the best idea ive heard so far!

Thanks so much for your help! Ill update the thread once im able to test this new advice. :slight_smile: