Midi and the CM4-WS Pi

I recently got the assembled CM4-WS Pi version of the Hypno. Very happy with it and still trying out all sorts of possibilities.

One thing I can’t get to work though is connecting a midi keyboard to it.

All tutorials/examples are for Hypno’s with a micro usb port which this one doesn’t have. I’ve tried all possibilities just connecting the keyboard to the USB A port but this is obviously not the way.

The only other way is via the USB C port but this one is also used for powering the device. Also, I’ve got it connected to a PC and the Hypno doesn’t show up as some sort of device midi can be sent to.

As I see it I will need a USB C hub and a usb to midi converter. Before I start buying stuff, am I correct in this? And if so, can someone recommend me cheapish models (preferably for sale in EU, yes I’m asking a lot :wink: that will surely work?


What model keyboard are you trying to connect?

All my midi controllers work conn ted to the usb ports but the hypno only receives midi on channel 16. This can be changed so make sure your midi device is sending on channel 16.
Also I know for sure that the hypno does not work connected to a pc or Mac via usb. The Hypnos is the host in this instance and does not work host to host (pc to hypno)
To ge5 around this I’ve used one of them cheap din midi to usb adapters and connected the usb to hypno and the din midi to my macs audio/midi interface.
Hope this helps.

I’m using some bog standard Alesis keyboard (Q49 ). I just want to store/recall presets with it so nothing fancy.

I’ve tried connecting it directly but also through my sequencer where I’m 100% sure I’ve used channel 16.

Thanks for replying!

Just an additional question. Can I use a midi to USB A adapter on the Hypno so I dont have to utilize the USB C port for this? This would simplify things a lot for me.

Forget about the MIDI DIN out on your board and try connecting from the Q49 USB port to the Hypno with a USB A to B cable (usb printer cable). The Q49 is class compliant and this should work.

Ah, thanks. I did try this several times but probably have some setting wrong on the Q49. It doesnt have a screen so it’s a bit hit or miss if it’s on ch16 or not for instance.

It’s good to know it SHOULD work. I’ll doublecheck the settings with midi ox on the PC next time I have time to test.

The Q49 Guide shows how to set midi channel, etc.

edit: I’ve got it working! Thanks a bunch!!!

1 Like