Hypno stuck outputting 720x480 split screen to 4K portable monitor (2.3 unable to run Hypno on screens without 720x480 HDMI mode)

For some reason my Hypno started outputting a double 720x480 resolution to a portable 4k monitor I use.It was previously working as expected, but kept restarting because I wasn’t powering it sufficiently. Then suddenly the resolution turned to 720x480 and the image doubled.

The weird thing is that the Hypno outputs fine to my 4k desktop monitor. And when starting up while attached to the portable external monitor doesn’t have a doubled image. Does anyone have any experience of what might be happening? Is the Hypno not recognising the monitor then defaulting to a low-res output, which the monitor then doubles?

I have never seen this before. Its possible that the hdmi is not being negotiated correctly, never seen a pi double the image so its probably on the display end. Poke around in the display menus, try some different HDMI cables and make sure they’re all snug.

If that doesn’t work please leave some thorough details about your monitor (model, all supported resolution modes, etc.) and maybe we can compare with other users or somehow give more solid advice.

1 Like

Thanks Ron. The portable monitor’s working fine with other devices. It’s just the Hypno that’s having issues.

The monitor is a UPerfect 15.6 inch. To use it at 4K it needs to be plugged into power, which it gets via a usb-c port. I’ve attached a screenshot (from EasyRes on my laptop) of the supported resolutions. The destktop monitor is an LG 4K something-or-other upon which the Hypno looks very lovely :slight_smile:

I can send a video of the weird behaviour if you like? Is there any way to get the logs of the startup? Or interupt startup and terminal into the Pi ?

Saw this on the RaspberryPi Forum: Pi4 won’t keep screen resolution.

(Don’t think I mentioned my Hypno has the PiCM4)

And here’s the output when running ioreg -l | grep EDID when the monitor is attached to my laptop:

"DisplayAttributes" = {"SupportsSuspend"=No,
"EDID UUID" = "4CF45641-0000-0000-231F-0103801E1A78"

and system_profiler -json SPDisplaysDataType:

          "_name" : "HS156KC",
          "_spdisplays_display-product-id" : "4156",
          "_spdisplays_display-vendor-id" : "4cf4",
          "_spdisplays_display-week" : "35",
          "_spdisplays_display-year" : "2021",
          "_spdisplays_displayID" : "2",
          "_spdisplays_pixels" : "3840 x 2160",
          "_spdisplays_resolution" : "3840 x 2160 @ 30.00Hz",
          "spdisplays_mirror" : "spdisplays_off",
          "spdisplays_online" : "spdisplays_yes",
          "spdisplays_pixelresolution" : "spdisplays_2160p",
          "spdisplays_resolution" : "3840 x 2160 @ 30.00Hz",
          "spdisplays_rotation" : "spdisplays_supported"

Yes a video of the bootup would be ideal. Logs should simply go onscreen if the program crashes… but I guess it didn’t? 4k monitors should be working ok since I have an LG one on my desk.

Can you check in the monitor’s menu what resolution your monitor thinks its selected from the HDMI when running the Hypno? You said double 720x480 so its 1440x960? (Which does not line up with the list above)

Heres’ a video of bootup

The monitor thinks it running 720x480. But as you’ll see at the end of the video, there are two identical images, one on top of the other.

I’m experiencing the same thing with my DIY kit with the Pi4 (not CM) on the version 2.3 software, running through a Roland V-1HD mixer that requires 720 or greater resolution. Plugged directly into a TV it’s working fine at 480p60 but if I plug into the mixer it doesn’t scale up the output accordingly, whether it’s booted with it or just plugged in while powered on.

Are there any diagnostic commands I can shell in and run to provide useful output for you @SleepyRon?

Just tested fresh SD cards with both 2.3 (current) and 2.2.3 (previous) releases. 2.3 definitely experiences the issue. 2.2.3 works fine for me at all resolutions, that I can tell. @SleepyRon hopefully this detail is of use to you.

also discussing this here: https://forum.sleepycircuits.com/t/unfit-signal-received-by-roland-v-1hd/

I suggested there to try to force a resolution there… but honestly still not entirely sure, this thing doesn’t support 480p only 720p and I believe that may be the main problem. So likely the resolution being selected in 2.2.3 is actually 720p and then its being upscaled from 480p internally… it appears that in 2.3 this is not working for some reason

Just to add similar experiences and info:

I’m running a Hypno (assembled CM4-WS version) into a HDMI video mixer (AVMATRIX HVS0402U) and am also experiencing the Hypno video signal being output at 480p. I can see that during boot/raspian splash screen it is at 1080 (the video mixer has an overlay which displays the resolution for each input) but as soon as the Hypno program kicks in it instantly downgrades to 480p.

Is it worth messing about with config.txt if this mixer is the Hypno’s semi-permanent home, or is it worth waiting for a potential fix instead (if new firmware is being worked on at the moment and a fix is on the cards)?

I figure it’s probably a case of taking the case apart and flicking the update switch in order to access config.txt from a PC, then moving the switch back and plugging it back in to mixer and power, to check the effect of any config.txt changes? If there’s an easier way please let me know!

It might help to adjust the config.txt and see if that allows Hypno to work better with your mixer in the short term. See Raspberry Pi’s Official Documentation on boot config video options for more info
A new firmware is in the works that will fix the resolution compatibility, and we’ll keep people posted as that comes together.