Hypno and OBS in Windows10 (RDNIS Driver Issue Solution)

When I connect my Hypno to Windows10, the device will be recognized as "serial USB-Device (COM4) and not like described as a network device. In OBS in the NDI Source, the Hypno is not recognized.

I started a new thread because the other threads are talking about the problems on a Mac.


My first suggestion would be to try powering the Hypno through the side USB port while also plugging the front USB into your computer (as discussed in the other thread). The side power will help when your laptop doesn’t supply enough power to Hypno.

Let me know if that helps.


Hi Brian,

Thank you for your reply!

I already tried it with powering seperatly and tried it again now.

I also have tried now 4 different cables, on 2 different computers.

When I uninstall the device and replug it, there is a message in the lower right corner like “RNDIS/Ethernet Gadget found” and some seconds later in the device Manager apears a “serial USB-Device (COM4)”

Yesterday I installed the Hypno1.7-PAL.img through Balena Etcher on the device and then I tested it by HDMI, everything is fine. But when pluged in, it’s not showing up as Network device as mentioned in the Video.

By the way, on: https://sleepycircuits.com/hypno-manual
under Firmware Update is still something written like “remove SD Card from Hypno”. I searched for a while for this card, till I saw the update instructions on the “Update” Page where it’s written correct.


I am sorry for the frustrations.

Have you installed the latest version of NDI Tools on each machine? If so, are you able to see the Hypno listed as a source in the NDI Virtual Input or NewTek NDI Video monitor applications? Also, do you have the latest version of OBS installed?

You can also try updating your USB and network drivers in the Windows Device Manager. You may want to try to reinstall certain USB and Network drivers as well.

I know it’s a long shot but do you have any way to test on a Mac (following the same steps as our video tutorial). I only ask because this will help us establish if it is something wrong with your Hypno or something wrong with your PC/OS.


P.S. Thank you for pointing out that error on the site. I have fixed it.


Have you had any success?


Hi Brian,

I checked the Hypno with a Mac and there NDI worked!

After this I cleaned my USB installations with USBDeview and in this program I can see the Hypno as RNDIS/Ethernet Gadget on COM9 but in OBS it does not appear.

Then after I searched with the keywords “RNDIS/Ethernet Gadget” I found this:

The download link in the thread above does not work, but on the moddevices page I found this:

And with the link in this thread:


I downloaded the correct driver, installed it and rebooted the PC. First it didn’t appear, I deleted the already made “NDI Source” in OBS and remade it, and NOW IT WORKS :wink:

So, this was a journey :wink:

Best regards and have a nice day!


1 Like

Wow, amazing work! We appreciate your patience in working this out and documenting it for anyone that may run into the same issue in the future!

Ran into the same thing, gonna try @Synthmill’s proposed solution soon, would love to start streaming out of the little box!

The link only gave me 2 files I don’t know what to do with, can you maybe talk me through this a bit more, since I clearly dont know what I’m doing :slight_smile: much apprecited!

Edit: I managed to get it working, the part I didn’t get, since I’m not familiar with drivers and stuff was how to locate and update the driver! Thanks a bunch @Synthmill!

1 Like

Hi Simon, I’m sorry that I didn’t reply. I’m not at home till friday.

That’s cool that it works now! Have fun with this cool module! :wink:

1 Like

Just thought I’d chime in that I’m having this problem as well. NDI works fine on my Mac … and in the past, I even had my Mac broadcasting via NDI to my OBS on my Windows system. However, I can’t seem to get the Hypno to show up in OBS. I had the issue where it showed up as a COM port in the device listing… then updating the driver makes it show up as a “USB Ethernet/RNDIS Gadget” … but that’s as far as I’ve gotten. Still nothing in the dropdown in NDI Source in OBS. Will keep at it…

Edit: Oh, and on a side note, ndi.tv, for whatever reason, doesn’t seem to be sending emails for NDI Tools download links, currently. I luckily had the Mac version from when I messed with NDI a couple months ago, but I’ve not been able to get the Windows version yet. Maybe the driver bundled with the tools would help?

@Naenyn I think it’s rebooting, removing the ndi source in OBS and setting it up again from where you are! You’re very close :slight_smile:.

Sadly, I’ve tried that multiple times now. OBS just refuses to see the Hypno. I tried another NDI source viewer as well (still haven’t gotten my Windows NDI Tools email yet) and that also said that no NDI sources were available.
Really leaning towards this being a Windows driver and/or config issue. Frustrating. Thankfully, it works great with a USB capture card, at least.
Please let me know if you have any other suggestions.

Edit: Finally got NDI tools after requesting them for a fourth time. Source Monitor sees Hypno on my Windows system fine. So, looks like it is a OBS issue. More to come…

Edit 2: Looks like I stumbled on the problem. In Windows’ “Network and Sharing Center”, I noticed that the network adapter associated with Hypno showed up as a “Public Network”. In my Windows Firewall settings, the firewall was turned on for any public network. When I turned it off, started OBS, and tried adding Hypno again, it showed up. As a followup test, I turned the firewall back on, removed Hypno, and tried to re-add, but it didn’t show up. Shut down OBS, re-disabled windows Defender firewall for public networks, then opened OBS and tried adding Hypno again … and there it is.

Edit 3: Random thought. Why would Windows Firewall effect OBS but not NDI Tools’ Source Monitor?

See Updated Windows OBS Thread