Hypno 2.3-Release

Hypno Firmware 2.3 is out! This is a debugging/maintenance update for the USB drive functionality and adds an often requested feature: CV control over the Hue knob! Check out the new pdf manual for more info.

Download and update instructions.

Patch Notes:

  • hue remapping on 2 side button combo gain pot, all the way to the right is hue mapping left is gain default

    • help text displays mapping
  • y axis centering reset on y crop of video shapes

  • On Device fat32 drive formatting for usb stick

    • pop up dialog (Y/N G/R w/ text onscreen)

    • startup center button hold activated

    • default logo video placed on usb @ sleepy/sleepy_loop.mp4

    • (drive still needs to appear in the linux’s /dev/ so some USBs may still not format correctly, mac os extended USBs still not format-able)

  • Bugfix: bug where some files would get skipped by the folder navigation due to a typo in code

  • Bugfix: Video playback freezes when left shape is unpatched


everything i wanted and more THANK YOU

1 Like

@SleepyRon Thank you for this gift!

Also the link to the new manual is popping up a signing into a google account.

Hello Sleepyheads, I purchased my Hypno in Jan of 2021 - I’ve downloaded the Hypno2.3-PI3.img.gz, extracted the file. Started up Balena Etcher and everything seemed fine but when I try to select my Hypno (Compute Module) in Balena, after initializing, I see the message “Too small”. The Compute Module displays a size of 31.3 GB and the downloaded file is 31.7. Have I downloaded the wrong file?

1 Like

I’m running into this “Too small” error too.

1 Like

Links are fixed whoops!

I think I know how to fix too small situation: will re upload an image built on CM3 and fix link above in a bit plz hang tight

1 Like

@SleepyRon FYI - Just downloaded the file from the link and I’m still getting the “too small” error.

Hello all!

Excited about this new firmware update, thank you @SleepyRon.

I first tried installing it as soon as I saw about it last night and thought I did it wrong because afterwards the display started showing as a square rather than fullscreen. Also couldn’t seem to turn on the hue cv option.

Retried installing a short while ago and basically accidentally turned on the hue cv. It seems either the implementation or the manual is backwards. Gain is turning on hue and the hue knob is turning on/off the help menu. Looks great now that I’ve got it turned on. However the display is still outputting at 640x480 and I’m not sure why.

Sure enough the manual was switched, good catch, thank you! I updated it just now.

Also confirmed the alt gain knob is in-fact the remapping as intended.

@KyleMunroe Hypno usually outputs at 640x480 or 720x480, it is not assigning a widescreen resolution? you are on pi3?

Yeah, before updating it was displaying widescreen, but not now. I’m using a Pi4.

@SleepyRon Still getting “Too small” error if I follow the instructions to un-compress the image. I tried just pointing balenaEtcher at the .gz file instead. It flashed, very slowly then failed. Hypno was soft-bricked. Had to re-download the previous version and flash it again. Back to where I was 2+ hours before. :unamused:

Yes @j4s0n as mentioned above I have been working on this issue the last couple of days. Sry bout the delay.

As mentioned above the image for pi3 was in fact too small for CM3 thats my bad, I just re-uploaded the file and tried it on my CM3 Hypno and it appears to be fine now.

Please try this link for the CM3/PI3 firmware. (Also linked on the firmware page linked above.)

1 Like

Has anyone else noticed the gain knob working differently since this update? I no longer have blackness when my gain knob is at 12. I’m not going to have the proper words to explain what’s happening, but it seems like the image is inverting more around the 9-10 position. Basically turning the gain knob all the way left does not do the same thing it did before. Just not sure if this was supposed to happen or not with this update.

not sure… but this update didn’t change anything about the gain knob as far as I am aware, some feedback modes are not totally black at noon position but the red one generally is. Is this after messing with the remapping somehow or just from boot?

i just update and get this massage on booting up:

MultiInput: DiviceWatcher Worker: reading Drive.
some [123.123456] rc.local[410] [warn:0] global /home/pi/lib/opencv/modules/videoio/src/cap_v41.cpp (890) open Videoio(V4L2:/dev/Video0): can´t open camera by index

Eurorack Version (CM3)
Use USB from PC to power up (input from the left side)
Use HDMI out to Smart TV samsung

No other inputs

Hello! After updating to version 2.3 (CM3), when scrolling through video files organized in folders, some of the videos freeze or I get this message and I have to restart.

(I used videos from Winter Walk Pack)

So my previous comment has seemed to stop happening. After rebooting for the first time since the holidays things are mostly back to normal. My only issue now is that I can’t get my midi controller to work. I use the nanokontrol2 and it’s not the first time I’ve had issues (korg kinda sucks) but this time I cannot fix it. Wasn’t sure if anyone else had trouble connecting with midi controllers since the update. Unfortunately it’s my only one so I can’t test another midi on it at the moment.

I’m using CV Thing to control MIDI and unfortunately, since the new update, it doesn’t work anymore.

Hey there Sleepy :slight_smile:
First of all thank you so much for all your work and creativity.
Hypno is a wonderful creature and am waiting to do so much with it.

I could not work with my usb stick yet but was hoping that 2.3 will fix it.
Unfortunately, I am not able to finish the update.

When I try to flash it it either says something like “the compressed archive might be corrupted”
or sometimes “the value of offset is out of range…”

ANY help will be much appreciated
keep up the amazing work

Yair Kass

@YairK please re download the file and make sure your archive extracts before flashing, also you will need about 32gb free on your computer after extracting the archive so theres enough swap space for the update to upload.

usually corrupted archive errors are due to incomplete downloads or lack of space on the computer.

1 Like