Hypno 2.2.3-Release

Hey Ron, I tried both reflashing my firmware and reformatting my drive, but I’m experiencing the same issue. When I insert the drive, my hypno diy is unresponsive and I cannot access the teal button even if I switch through the shapes.

I also tried live video in through my capture card but what happened is it showed a color spectrum of vertical bars going from white to black with the colors in between, but the teal button showed up as soon as I inserted it.

Where it gets weird is about after ten seconds, the teal button disappeared showing a pink screen for a second and then it switched back to the color bars. After a few times of it going back and forth, it stayed on the pink screen and the color bars only showed up for a second as the teal button switched to red.

Hey @Geoff3 ,

I am still not entirely sure what is happening here ( I have been testing as many drives and formats as I can on my end here but they all appear to be working fine so I think maybe we are having some freak issue or something here) but I think the next step would be to get an exhaustive email from you to support@sleepycircuits.com with the following info in one place:

  • The power supply model you are using with your kit and its rated current output.

  • A phone video following the cables and showing the screen what happens when you plug in a capture card, please make certain to follow in the vid how youre powering the Hypno since lack of current can make USB devices malfunction.

  • Model info of used capture card (USB version, model number, manufacturer etc.)

  • model of your usb drive (USB version, model number, manufacturer etc.)

  • last firmware version number where your usb drive was working (so I can see if anything has changed since then) and plz confirm if rolling back to this firmware revision makes your USB drive work again.

  • Confirmation of the method of formatting the fat32 drive (plz use the utility mentioned above) and the flashing OS (Win/Mac)

  • A screen cap of the directory structure of the FAT32 drive youre plugging in (please use the cube1.mp4 and nothing else, it will not enable the teal shape if there is no valid file present on the drive)

  • a phone vid following all cables and hardware setup when plugging in the drive including if the screen does anything when the drive is plugged in (once again please make sure to follow where the power is coming from.)

If you are seeing the teal shape and bars that means that you are receiving a feed from your capture card, the connection seems unstable so I would recommend trying to add a second psu plugged into your microusb as well as the usb-c port on the pi3 Hypno. This would indicate that your usb ports are working fine but for some reason cant get a stable connection. If screen returns to an all pink screen means that the device has disconnected and Hypno auto switched back to the sin shape, it appears to be bouncing back between the connected and disconnected state.

Please also see: List of USB Accessories that work with Hypno in case it offers any clues to you as to what may be going wrong, theres a lot of good usb device specs in there.

Anyway if all else fails and your order is domestic its no big deal to have you send the unit for me to verify physically, we can figure out details over email and hopefully we can get this sorted for ya soon!

I went ahead and sent an email, but I managed to get the live video input to work again.

Instead of using my tv as the video source (which was then connected to NDI via ethernet cable hooked up to my router), I connected my laptop to the Hypno with the capture card and HDMI, and then used the HDMI out on the Hypno to connect to the tv. Thankfully it wasn’t anything major.

Also, my USB drive worked on the firmware 2.2.2 but on 2.2.3 the cube showed up briefly when my drive was formatted to NTFS (It didn’t show up on exfat or fat32)

Thank you for taking the time to help me out!

1 Like

I’m a new hypno owner, experiencing the same thing. Rotating cube shows briefly and disappears. I’ve tried around 6 USB sticks and a wide variety of formats. On Firmware 2.2.3 PI3

About to try flashing 2.2.2.

After flashing back to 2.2.2 was easily able to load video files from the USB formatted fat32. No luck with 2.2.3.

I’ve got an issue after updating to 2.3.3-release
I’ve got a pre-build CMV4

my feed is acting as if there are CV inputs. many characteristics waiver around and I can’t seem to figure out how to stop it.

Here is my example where there are no CV or Midi signals going to the Hypno:

any advice?!


Hey @dilligaf not sure how old youre unit is but if youre getting some jittering you may have a unit that was part of the recall batch from back in the day, please see the instructions in this thread to get that repaired: Voluntary Recall on Noisy Hypno Units ( Pre Dec 2020 )

1 Like

Hey @sanzliot are you formatting with windows by chance? I still havent been able to get completely to the bottom of this issue yet unfortunately but y’all should know I’m currently rewriting backend code so I’m hoping this will be better in the future.

Currently it seems that something about windows formatting is tripping up the USB recognition bc there have been instances where we sent out a drive formatted by us here and it was working correctly for users on 2.2.3.

I have been sending along usb drives to people who are having these sorts of issues so maybe I could trade you one for one that isn’t working for you so I can try to test it on my end? Lmk and we can get an email chain started so we can manage the shipping back n forth.

I’d be happy to help. Happy to ship USB drives or try formatting on different platforms, etc. I have a Mac and PC. 2.2.3 I seemed to be unable to get a solution to work on Mac or PC but i was only using mac’s disk utility, maybe there is a different tool to try for fat32 on Mac?

I would try the SD Memory Card Formatter | SD Association I posted above to format to Fat32.

If that doesn’t work lets try to get a drive exchange going so i can have a confirmed not working one, just shoot us a mail at support@sleepycircuits.com

1 Like

So I received a usb drive formatted by the guys at Sleepy Circuits, and it loads up just fine… I’m not sure what the difference is, I had previously tried all the suggestions and formatting programs, and yet the only one working was the one shipped to me. I have to believe then at this point that it’s not a hardware issue, but a file system format issue. I’m a little light on free time right now, but I’d suggest trying different sources for formatting (ie, from Linux etc), because it seems like the culprit is the file system formatting.

1 Like

i use pre-build CMV4 and have the same issues above. firts i do it with mac it works but after win. no divice are regotniced from hypno

i reinstall evreythik and use only mac now it works agin seems problem with windows

Hey yall, thanks for all the feedback, after some thought I think the best option here would be to implement a formatting option into the Hypno engine itself so that we have no issues with formatting OS inconsistencies. I have added this to the development backlog and hope to deliver it by the next patch.


I just received a Hypno kit, and wondering if there are any performance difference between using Pi4 over Pi3?

Pi3 A+ is more streamlined for Eurorack use, Pi4 is better for standalone users. We’ve made a handy Pi Selection Guide
if you want to take a look at the differences between Pis!

1 Like

Thanks. I’ve seen the Pi selection guide, I was more curious about performance wise (and for example thermal)

General consensus so far has been that theres no perceivable performance difference. Same with thermals.

Only slight performance diff is that NDI streaming is a slightly smoother since it relies on the CPU more. Also NDI works without an HDMI plugged in only on PI3 at the moment for backend driver reasons.

I have been told video decoding is a little bit smother on the faster PI4, but I dont think I could tell in a blind test tbh.

1 Like

Nice, thanks for the thorough explanation :ok_hand:t2:

1 Like