Hypno 2.2.3-Release

**May 2021: 2.2.3-Release: Hypno Firmware - Sleepy Circuits

  • folder based file navigation for usb loading

    • help mode displays file and folder names
  • A Resource pool now preserves objects in memory for the last ~10 videos used, therefore switches to recently used videos are sped up.

  • Fixed bug where presets where not saving to USB

  • Fixed MIDI preset loading crashing

  • y offset drift

    • some shapes polarize while others have a y offset in its place
  • removed fractal axis and just have a modulation ctl (like scan)

    • y mod doesn’t do anything in polarization shapes, polar mod is independent of fractal mod now
  • Enabled cropping/luma-keying/aspect stretch for most shapes

    • X/Y cropping/alt shaping

      • sin

        • dual sin/tri modulator function
      • tan

        • dual tan/tan modulator function
      • circle

        • diameter and squash
      • poly (formally square)

        • x/y stretch
    • lumakey

      • sin

      • tan

      • circle

      • poly (formally square)

        • not actual lumakey but similar effect, controls edge smoothness
    • aspect stretch

      • poly (formally square) - num sides (aspect stretch already possible with crop x/y controls)
    • New manual up: Hypno Manual


Hey there. So I just got my Hypno Kit a few weeks ago and have been loving it so far. I built it using a Pi4 so I’m on the 2.2.3 beta firmware. Just want to clarify that I’m going to have to take it apart to get the SD card to update the firmware, right?

Is there a specific folder structure/naming we have to use? I haven’t been Abe to load videos from a USB using folders.
BTW, the new update is awesome, tanks a lot!

Yes, just follow the steps in reverse, should be pretty straightforward.

No just single level structure, check out the manual on docs.sleepycircuits.com I made a few nice updates to it yesterday. There are instructions for preparing video for the USB. A video quick-guide is also on the way for this feature.

Also there is now a link to my tested working and formatted video for Hypno’s USB of all the free video packs: Sleepy Free Packs - Hypno Formatted.zip

1 Like

Thanks Ron! I downloaded the packs and put them in the root folder of my USB but it does not recognize the USB drive, It doesn’t show the teal shape in the hypno. When I put the videos all in the root folder (not in folders) works fine tho. Could it be the adapter I am using?
I was trying to reinstall the firmware with balenaEtcher, but the computer Module size is 31.3 Gb and a warning says ‘too small’ and I can not select it, is that normal?
Sorry for all the questions, thanks for the help!

You guys I just wanted to say a deeply felt thank you for this marvel, I can’t begin to tell you how much fun I have had with Hypno since like 2020. Used it for DJ gigs, tripping nights, decoration in certain occasions, and just plain sleepin’ fun. Reactions have been so good @gigs, people just love it.
Great update, super nice for the regular shapes and great job on the video input (and output) implementation.
Grtz from Amsterdam


Thanks @mazureofficial! Its actually been a rough couple of days so I appreciate that :slight_smile: I’m glad youre enjoying the Hypno in all the contexts!

@Synthesaurio So you where able to flash this firmware or no? Last firmware doesn’t work with folders so this sounds like you’re still on the last one perhaps? This firmware should recursively scan the whole drive for valid folders and index through them when root (fully CCW) is selected with the folder selection, I recommend doing this while help mode is on.

Thats certainly weird that it says not enough space on the compute, (especially since they’re specced to be 32GB from the factory lol) I can re-upload the image and make sure its under that size when expanded. (I should be able to do this by the end of the week.)

Also just gonna put this link here since this section describes the folder navigation controls, plz make sure to check out that graphic: Hypno Manual - Sleepy Circuits

1 Like

I did flashed the firmware a couple of days ago and it said that I was on version 2.2.3 when starting the hypno (maybe I got another v2.2.3?). I downgraded to 2.2.2 and worked fine, but when I try to go back to 2.2.3 it says that the device memory is too small. I can see that the img file of 2.2.3 is 31.91, which technically should be ok, but not sure how it works lol.
Thanks for your help Ron

ah yeah the last one was the-same label “2.2.3” but it was a public beta technically, I think maybe ur still on the beta, ill work on exporting a smaller image today.

1 Like

hey @Synthesaurio ive uploaded a smaller image to thesame link for the pi3/cm3 version, it is up on the Firmware Page

Plz lmk how that works out for ya.

1 Like

It working! Thanks a lot @SleepyRon , having so much fun with the video input. Awesome update!!

1 Like

I just updated my hypno but now my device no longer recognizes my usb drive when I plug it in. What can I do to fix this issue?

Welcome Geoff3! can you please let me know if youre using the pi4 or 3 version and what format your USB drive is?

Thanks SleepyRon! I’m using the pi3 version for my diy and my usb drive is formatted to fat32.

Ok I’ve got a weird version of this USB issue, DIY, pi3:
3 USB sticks, one was brand new, all FAT32, wouldn’t work regardless of directory structure.
I had a CF card for my camera in a USB card reader sitting there and thought why not - it worked if I put the videos in the DCIM folder where the camera saves the images.
Then I formatted that card, FAT32, wouldn’t work. And here’s the crazy part - I put that card in my camera, took one image, then added videos to the DCIM folder and it worked again.
Live video capture is no problem, btw.

Micro USB drive, formatted NTFS - doesn’t matter volume size or block size, the demo cube just comes on the screen for 2-3 seconds then disappears, and looks like the volume unmounts. Images doesn’t show at all. exfat doesn’t work at all.

CM3 with fresh flash of 2.2.3

Thanks for all the feedback yall I’m looking into this problem now.

From my initial testing my usual FAT32 Samsung 64gb USB 3.0 drive works on freshly flashed pi3/cm3 based units but I will be preparing/reformatting a few new drives and formatting in various ways to try to resolve this.

In the meantime if you have a cm3 based unit and experiencing remounting or no drive recognition at all please make sure you are using a high quality micro to usb a converter as Ive seen those be very poor quality before (not working out of the box on one particularly unlucky amazon order for me).

FAT32 should be the most reliable formatting in theory… @dad how are you formatting? I would recommend using this SD Card Formatter Utility, Just tried this on a microSD card (note this util also works to format any usb flash drive also) in a reader and dropped winter walks folder on it and it appears to work.

@Geoff3 any luck with your drive if you reformatdruve and/or reflash the firmware? I just retried the pi3 (and cm3) version and I’m getting expected operation of a fat 32 usb drive and microsd with reader reformatted with the utility mentioned above.

1 Like

-Scandisk 128gb usb 3.0 micro usb/dual port memory stick
-Generick scandisk micro sd card reader with 32gb card through otg dongle (verified working on my phone)
-32gb usb 2 through otg dongle

Tried formatting through windows and through the sd card formatter utility, no difference vs operating system doing the formatting. fat32/exfat is never letting anything mount/play, but if I go NTFS it will let the birds mount for 3-5 seconds before unmounting.

Just ordered a Samsung 64gb usb 3.1 drive to try next

1 Like

I’ve formatted with 2 PCs running Windows 10 and 11, previously with the system formatter, just tried with SD Card Formatter Utility, still not seeing it. I run the slow version.
Just using the cube.mp4 to test. The card reader shows activity on connect so it looks like it’s reading it.

So far the only apparent commonality here is windows and pi3/CM3… is there anything different about how that os uses the filesystem?

If a CM3 unit is not working, a hardware problem is possible on the Hypno end we have had some issues with this component in the past.

First off I would advise a re-flash of the Hypno2.2.3-PI3-Release.img to make sure we are on thesame firmware. I just re downloaded the file from the link in the wiki and flashed it to a pi3 and cm3 unit and am able to see SanDisk Ultra 16GB through a USB 2.0 Card reader with only Cube1.mp4 on both so I’m a bit confused…